Get in touch
Back
Maintenance

Upgrading new interface version

Completed 23 Jun at 04:00am -03.

Desktop & mobile interface
Completed

Posted 23 Jun at 04:00am -03.
Started

Main UI can have some items unavailable in the time window.

Posted 23 Jun at 01:00am -03.